Node RED Website not loading

Hello everyone,

i am running node-red on my Raspberry Pi

22 Mar 19:32:42 - [info] Node-RED Version: v1.2.9
22 Mar 19:32:42 - [info] Node.js Version: v12.21.0
22 Mar 19:32:42 - [info] Linux 5.4.83-v7+ arm LE
22 Mar 19:32:44 - [info] Paletten-Nodes werden geladen
22 Mar 19:32:50 - [info] Einstellungsdatei: /home/pi/.node-red/settings.js
22 Mar 19:32:50 - [info] Kontextspeicher: 'default' [ module=memory]
22 Mar 19:32:50 - [info] Benutzerverzeichnis: /home/pi/.node-red
22 Mar 19:32:50 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false
22 Mar 19:32:50 - [info] Flow-Datei: /home/pi/.node-red/flows_raspberrypi.json
22 Mar 19:32:50 - [info] Neue flow-Datei wird erstellt
22 Mar 19:32:50 - [warn]

Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten Schlüssel verschlüsselt.
Wenn der vom System generierte Schlüssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise
Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben.
Ihre Berechtigungsnachweise.
Sie sollten Ihren eigenen Schlüssel mit Hilfe der Option 'credentialSecret' in
Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlüsseln.
Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

22 Mar 19:32:50 - [info] Flows starten
22 Mar 19:32:50 - [info] Flows gestartet
22 Mar 19:32:50 - [info] Server wird jetzt auf ausgeführt

It is a clean installation (provided raspbi script) but unfortunately the default webiste wont load.
With Firefox, Edge, Internet Explorer or any Browser the tab wont finish loading, it says "node-red" as the tab description but the website itself wont come up. I already entirely reinstalled the raspberry pi, without success.


How do i get it to run?


what happens if you you try the link in the log output...

... (accessed on the PI)

Hi, it just took the pi and launched it locally, it works i can see the landing page come up.
how to configure the listen interface properly?


So it does work - good.

Now what IP does the ip have?
Enter ifconfig or ip address in the terminal.

Once you have the IPV4 address - can you ping it?

Lastly try the IP in the browser.

Hi Steve,

the Pi has (as you can see in the screenshot, IP: and the Tab is showing "node-red" as tab description, but the page wont load up and stays white.

I changed the settings.js ui Host to, if i try to launch node red locally it works with the new listen address, but as soon as i try to connect from my pc (same subnet!) it shows a blank white page.
there is no firewall or any gateway in between

I dont get it tbh


Yeah, i seen the screen shot - I just want it verified.

Hello Guys, i was curious and tried to open the webpage on my mobile phone and it works!
There is no Problem with the Pi, it must be something with my pc/notebook i try to access it.

Thanks i will close the thread!

oh well, result.

Hi Steve, i can ping it, i am connected to it via ssh
it is obviously on application layer - ms defender or whatever.
My other windows machine works

Hello to everyone who tried to help me, it was indeed my sophos home web-protection blocking the access, i did not get any notification about it to be blocked. I created an exception and now it works fine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.