Nodes' edit dialog boxes no longer open

#1

I installed node-red on my raspberry pi.
I’ve created a few flows with no problems. I added some new custom nodes, and with the latest addition I’ve lost the ability to edit any nodes.
I had difficulties installing SQLite and MySQL nodes, but got them added to the palette.
I can drag new nodes into my flow, and delete them. But now, when I double-click on any node in my flows, nothing happens. Same with .
This happens from the browser on the raspberry pi, and from my desktop using Chrome, Firefox and Explorer.
I’m dead in the water until I can fix this. Help!

#2

Have a look in the browser javascript console for any errors.

You may need to uninstall any additional modules you’ve added one by one to see which is breaking the editor.

#3

Have you updated the pi using the node red update bash <(curl script?

Also restart node-red and check for any messages in the node red log. Don’t forget to refresh the browser windows after restarting node-red.

#4

Thanks all!
I wrote down all the modules I had installed and uninstalled the modules one-by-one, rebooting the Pi each time. No help.
I backed up my flows and deleted the files in the .node-red directory.
I typed node-red-start and that launched a reinstall/repair script.
After the reinstall everything worked and I added my modules back, no problems now.

#5

You did not answer the question as to whether you had run the update script.

#6

Yes, that appeared to be the script that was launched when I tried to start node red after deleting all the files in the node-red directory.