NR 1.1.0 Update Issues

Hi and Thanks for the great improvements implemented in the new NR1.1!
I'm coming directly from NR 1.0.6 and got it running on different machines.
RPi4, "High" Performance Server (10core AMD DDR4 RAM ubuntu and so on)
a normal "office" machine with micro atx and mobile chipset...

Here are some things that come to my mind using the new update, some of them I have already seen here:

  • The performance has become worse over all
    especially on RP4, that includes scrolling, opening context, opening nodes, coding in f-nodes and so on, it sometimes kills my mqtt server, that is running on a RP4(4gb) as well. (HassIO Docker)
    there were no problems with 1.0.6. and the performance was "instant happening".

  • no scrolling on touchscreen devices i have here seen an ipad Pro issue but have myself some androids (9.0 and 10)

  • the grouping function is awesome, but it would be awesome as well if one could remove grouping as easy as this. eg like the connection in a flow: click it, highlight red, press del -> group gone.

-some configurations dont work as before (e.g. alexa-remote-2)
I would like to invite others to tell if they have the same issues here.

if i can contribute in any way or test something out, please let me know.

Sincerly Lindsay

I use node-red-contrib-alexa-remote2 a lot and haven't noticed any effect of 1.1.x on it directly

(I have UI issues and glitches but the nodes seem to still work OK)

What issues are you having with it?

The Ipad scrolling issue is known about and is being worked on

V1.1.1 was released yesterday and is said to perform faster than 1.1.0

The del key is dedicated to deleting things so it would be in-appropriate to use it for this

Yes, I mean in that manner.

I'll try asap

Scrolling sometimes needs seconds to start running. If it does it is performing stepwise. I don't know if there has been something like changing to more Serverside processing / cutting Clientside processing...

Opening a function node sometimes needs 10+ seconds too (we're talking about 100 lines of code max and everything on gbit lan)

It doesn't matter if I use a FHD laptop screen or the 4k-"coding"-display

NR UI has to be refreshed Everytime after changing the browser tab. (Ajax?)

I did not experience glitching yet

I am using the UI on the same computers as before. On chrome and chromium. So this can't be the problem.

To the Alexa thing:
I cant auth via proxy and cookie anymore. Same correct (?) settings as before.
In the past I wrote a python script to automate this authentication process by the time the cookie has to be refreshed, but it doesn't work manually anymore either. I haven't found out yet if this could be a particular issue of Amazon Germany.

Thanks for your fast

return answer;

:grinning:

This has also been tried to solve in 1.1.1, maybe check that out and report if it solves it, see https://github.com/node-red/node-red/issues/2631

Are you saying you open a function node in a browser running on a "normal" computer, i.e. not a pi?
Because the function code is loaded already in the browser, so it has nothing to do with the network connection.

I'm in UK and not noticed any major issue - currently using V3.10.0

Yes, sorry for the imprecision.

Using a normal computer, browsing the UI with chrome on windows on my work laptop (pretty descend thing. So should be no performance issue), opening a function node for editing the code in it. Opening the editor and typing is very unresponsive.
But I need to say that this wasn't an issue ever before and the client systems I use haven't changed at all.

Could you maybe share that flow ? Maybe even @cymplecy could test it, since he is also using windows with chrome, right?

How many nodes does your workspace have in total?

I run my flows on Windows but I use Pi Chromium as my browser/editor

And I'm having unique UI issues with my setup that no-one else is getting so not best person to test :frowning:

ah, sorry, confused that. Actually an interesting setup, using windows to run the flows and the pi as the editor :slight_smile:

Maybe you need someone who is opening the editor on a pi also to recreate your UI issues? I guess you have updated the chromium on that pi etc.

I appreciate your effort!

I think Simon wont get a kick out of testing my flows.

Its 19 active flowtabs with 1555 nodes in total.
Of which 394 are more or less complex functions.

I am using about 30 independent mqtt topics in this set up, open weather map, magic hue, google contrib, alexa remote, but none of them super intensively. I know that hue contrib is very hungry in behalf of polling the bridge so I use only one node for each light and one for each scene (not so much) and linked between flows when necessary.
The functions are best practice and efficiently coded, i'd say.
Probably, because everything worked totally flawless on 1.0.6.
Even the dashboard is super responsive. RP4 (Serving) is on 27% CPU mean. havent looked up ram, but this cannot be an issue at 4gb.

I am using about 15 files I/O which consist mostly of JSON Data (persisting context where needed, 2 bitmaps for the dashboard, ).

Tesseract (OCR), that i had in mind first is inactive.
But I think this all is no reason.

Its all about the responsiveness of the UI. There are no (more) noticeable performance issues of NR itself. As far as i can tell by now.

As I said if opening a function node editor is slow this has nothing to do (at least as far as I know) with the raspberry that is running Node-RED, this is purely something that happens in your browser.

I am running out of ideas with the information you provide. Maybe Nick can help?

Edit: Have you tested v1.1.1?

Second edit: Is also opening a template node editor slow?

To be honest, not worth discussing until 1.1.1 (now 1.1.2) has been tested.

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.