Problem with dashboard layout

Hi, I've a problem with layout design of official dashboard, I can't move any object, I've try with nodered 2.1.6 and 2.2 and with dashboard 3.1.4 and 3.1.5 but when I open debug tools on chrome I receive this error: DevTools failed to load source map: Could not load content for HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE.
I've try to clean cache, open in different browser but problem still remain.
Thanks in advance

The warnings about missing map files are REALLY annoying! But this isn't a Dashboard issue, it is down to the browser.

It is only a warning, it makes not difference other than if you try to view the sources tab where you will see the code that the browser gets rather than the source code (which is what the map file gives).

You can use the settings in the developer console to hide the messages.

But I'm not sure that relates to "I can't move any object"?

I've checked again, i've one issue:

A page or script is accessing at least one of navigator.userAgent, navigator.appVersion, and navigator.platform. Starting in Chrome 101, the amount of information available in the User Agent string will be reduced.
To fix this issue, replace the usage of navigator.userAgent, navigator.appVersion, and navigator.platform with feature detection, progressive enhancement, or migrate to navigator.userAgentData.
Note that for performance reasons, only the first access to one of the properties is shown.
1 source

It seem it's a Chrome new version problem. If confirmed I open an issue on github

That is another warning and is just letting you know that the browser userAgent is about to get limited in order to restrict advertiser profiling. This is an issue that needs dealing with in one of the vendor front-end libraries included in Dashboard.

Ok, at this point my ignorance on the subject is evident and I apologize. I can't figure out what the problem is, however trying on another computer on Chrome the problem isn't there. At this point there must be a problem on my computer, I will try to uninstall Chrome and clean everything up.

No need, that's what the forum is for.

I'm still not actually sure that you've described your problem? You've mentioned a couple of what you thought we symptoms but not the actual problem?

Obviously I have not explained myself well, the problem is that in the dashboard layout editor I cannot move any element. When I try to move it it just highlights the text

Ah, well that is because the Dashboard does not have drag-and-drop enabled.

You use the Dashboard side-panel to change the layout.

Which also gives access to the layout editor.

Yes, I have this problem on layout editor

Post a screenshot showing what you are seeing where you cannot move the widgets. You can paste it in here.

I had this issue and realised that the size setting is in AUTO . May not be in your case, just check if the size setting is in auto.


Please give complete information when asking for help. It becomes very frustrating when information is drip-fed through to the thread. Had you said what the problem was from the outset, we could have helped a lot faster and with less wasted time on our end.

It is probably a translation problem, I have mentioned the layout editor several times, my mistake was that I called it layout design in the first post, then I used the name layout editor, obviously I did not express myself well, I think the most immediate way is post a video with the problem, tomorrow I will

Before you do that force a cache clear in the browser via the menus. In Chrome that is in Settings > Security and Privacy > Clear Browsing data > Select Cached Images and Files > Press clear data. Then force a refresh of the dashboard page.

I cleared the cache a few days ago and tried again today but didn't fix. I tried to delete it again and now it seems to work but a new problem has appeared: in the tabs list of the dashboard now all the tabs are duplicated, on the former I can perform the classic operations, on copies each key pressed does nothing. However, the problem is clearly of the computer because on another it does not give problems. At this point I will do a reset.

I did a reset to my computer and as suspected the drag and drop problems disappeared. However, I have noticed that there is a problem that continues to present itself, on this and on other computers. I have three tabs in the dashboard, on the first one called Home it is not possible to change the layout, if I press the layout key nothing happens, if I press the layout key on the other 2 it works correctly.
After clicking on layout in the home page, the tabs are duplicated. I am attaching a video to better understand the situation.

Doing some tests I discovered that the problem occurs with version 0.1.8
of node-red-contrib-ui-timelines-chart, I open an issue on its repository

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.