[Question] Will this sparkfun-20x4 work with node-red-contrib-lcd20x4-ic2?

I have this display.

I want to use it on a RasPi.

This node:

Should work?

I would say "give it a try" - assure you connect the proper pins.


I am just so much on edge just now, it is difficult me doing much with any semblance of confidence.

It would only need the I2C power connected and not the 3-9v power input.

Andrew, Hope you don't mind, I updated your topic and moved it to the hardware category - might get more exposure and assistance. At minimum, should make it easier for future readers to find.

Please update it with your progress - could turn out to be a good thread.

No problems Steve.

Brain is still not really working. I am amazed I can even type with things as they are.

Well, no luck since the original posting.

But here's a recap of what has happened.

The display I have this display. is 3.3v so there is no problems about connecting it to the RasPi directly.

It comes with a built in AVR and has I2C, SPI and serial connections.

Alas Sparkfun are not being helpful with What it does out of the box.
But digging and reading more, I have found this:
It comes with QWIIC installed. What ever that is.

But I see:

This display can now communicate in three different ways: serial, I2C, and SPI. This version comes equipped with a Qwiic connector, bringing serial LCDs into the Qwiic ecosystem.

Again, great. But I am somehow missing the magic key to get this thing working.

Again: I am sorry for bringing it up here. I have created an account with Spark fun. It took 3 days to get my question authenticated (meaning others can read it) and it has been a few days since then and no one has replied.

SparkFun don't seem to have a direct help process. When I went to their web page, it just fobbed me off to the forum for help.

So if I may ask, what are you getting on the screen? What have you tried? I have one of these (something similar) laying around as well and am curious as to how much is/isn't working

Good news! Kinda.

I kept digging.

I found somewhere which has some code and installed it.

It works!

It is all done via python but .... it works.

What is annoying though is the codes/commands they use.

In their code there is a command, and if I go into python and do that command, it says it isn't recognised. Syntax error or something.

So I now need to start digging in another direction.

But! Progress has been made.

In answer to your question:

I had a node that talks to 20x4 LCD modules on the I2C bus.

Alas it isn't compatible with this.

How ever when the node initialised..... The screen was doing weird things. Which at least proved the screen was/is working.

All behind me now. The quest now is why that command isn't accepted when I put it in, yet in the script it is.

This link really helped me:

Start here.

Scroll down to the installation part.

More instructions there on installing what you need.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.