Raspberry Node-Red - how do I get the ioBroker nodes

I just started my first steps in home automation and with node-red.
I installed node-red on a raspberry and it runs well. I have as well an ioBroker container on my Synology running.
Some days ago I had already ioBroker nodes in node-red and I could open node-red as well with the link in ioBroker. Now it doesn't work anymore and the ioBroker nodes are not available. I have no idea what went wrong.
I read somewhere that node-red-vis brings the ioBroker nodes. If I try to install it, I always get error messages.

npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)
npm ERR! code 1
npm ERR! path /home/pi/node_modules/node-red-vis
npm ERR! command failed
npm ERR! command sh -c -- node node_modules/iobroker.vis/lib/install.js
npm ERR! node:internal/modules/cjs/loader:1024
npm ERR!   throw err;
npm ERR!   ^
npm ERR! 
npm ERR! Error: Cannot find module '/home/pi/node_modules/node-red-vis/node_modules/iobroker.vis/lib/install.js'
npm ERR!     at Function.Module._resolveFilename (node:internal/modules/cjs/loader:1021:15)
npm ERR!     at Function.Module._load (node:internal/modules/cjs/loader:866:27)
npm ERR!     at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12)
npm ERR!     at node:internal/main/run_main_module:22:47 {
npm ERR!   code: 'MODULE_NOT_FOUND',
npm ERR!   requireStack: []
npm ERR! }

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/pi/.npm/_logs/2023-03-25T17_40_40_399Z-debug-0.log
type or paste code here

I tried to fix the mentioned above issues (the debug installation, etc.) without success.
I installed everything from scratch - still the same failure.
At ioBroker I get the following in the log:

|2023-03-25 18:57:17.506|warn|25 Mar 18:57:17 - [warn] Die Verwendung von editorTheme.palette.editable ist abgekündigt. Stattdessen externalModules.palette.allowInstall verwenden.|

node-red.0|2023-03-25 18:57:11.351|error|25 Mar 18:57:11 - [error] Error: getaddrinfo ENOTFOUND Http:// at GetAddrInfoReqWrap.onlookup [as oncomplete] (node:dns:109:26)|
Does anybody an Idea how to fix it?

The node-red-vis node was last updated in June 2016.

In Github issues there is "Not installable anymore in NR 1.0.3" unanswered since November 2019, which looks like the same as your problem.

It looks as though this node is abandoned.

Thank you for your fast response. Do you have an idea how to get the ioBroker nodes?

No I don't. I am afraid I don't even know what iobroker is.

However, there are general purpose serial in/out, mqtt, http etc nodes which you might be able to use if you know how iobroker does it's stuff.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.