RaspberryPi OS Bullseye and xrdp not working

I am trying to set up a new Raspi with Bullseye. Unfortunately xrdp is not working. Does anybody have the same problem and eventually a solution?

In what way does this have anything to do with Node-RED?

yes, it has to do something with node-red as I am editing my node-red flows using my Windows PC and xrdp. I suppose, that I am not the only one doing it this way.

no, but then, there is no need to do that. You can simply access the remote node-red via a browser...


you are right!
What I meant is installing and update node-red and editing node-red related files. This is much easier with xrdp than with a direct connection to the Raspi. Especially with 10 Raspi which I want to manage.

I have had mixed results with xrdp over the years and tend to just use VNC.

Is VNC not an option?

If not, then I suggest you have a look at raspberry pi forums - they will likely know the reason or be better equipped to help.

Personally, i just use SSH (terminal) and mc for those times when I cant remember how to chmod or want to edit a file.


That looks very good. I will give it a try.

No, it is a raspberry pi config and apps question.

Node-RED has a web-based Editor and doesn't require remote desktop access. Running remote desktop on most Pi's slows them to a crawl when used along side a healthy set of services.

I guess I solved that - you need to create an additional user to get an RDP session - now it works fine for me. :wink: You cannot use pi - as this user probably is already logged on, on your raspberry desktop.

However I use the Webinterface to edit my NodeRed flows - is much faster as on the Raspberry. :wink:

If you create a new user, you have to add the new user-id in the sudoers etc .to have the same rights as the pi user.

looks very good!

I am not very familiar with unix.
Which commands do I need to add a new user with the same rights as pi?

PS: I of course use google chrome on my PC to edit my flows. I was putting it wrong in my former post.

I am also not a power user in unix, so I had to Google as well.
But I think, you can google as well. So addusers and a user to sudoers or looking to which groups pi and add the new user to the same groups should be possible. I managed that - and I am sure you will be able to do this as well.

I successfully got access to my Raspi with xrdp useing a different user! Many thanks for the tip
Still have to find a way to add it to sudoers.
This link should possibly help.
Great Web-Site: Raspi Support

I totally forgot MC. Great tool.
Many thanks for the tip.

did you install it?

It is my go-to LONG before RDP/VNC.

yes I did. Like it. Very helpfull!
I used it long time ago and then forgot it :wink:

1 Like

this helped me with xrdp! :+1: :slight_smile: