RevPi and Remote AIO server

Hi All,
I'm here to ask for a suggestion.
I currently use node-red and since some weeks ago I've been started to test new Revolution Pi and AIO module. Since I work on the RevPi, no problem with node-red nodes. I configure the AIO server as localhost:8000 on my nodes and everything is ok.
But, when I try to connect from another machine (different IP) I always obtain

Stopped reconnecting. Max Reconnections reached!
Closed connection to WS Server!

And this is strange for me because there is not so much stuff to configure in the node and that is the correct IP of the RevPi.

Do you have any Idea?

I've tried several attempts by changing user and permissions on the remote pi but I have no positive results.



I try to go deep into the topic.
Here following, my 2 attempts to connect RevPi AIO server


In the first, I've tried to connect using authentication (both with pi user and node-red user) while in the second I've tried with no authentication.
Always the same result.

I've also tried to use the same user (and password) for RevPi and the remote Pi. No luck.

This is what I have on the remote Pi node

without any possibility to select an Input pin.

Of course on RevPi I can make my choices

Please refer to this


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.