Since version 1.0, Japanese inline input has become difficult to use

There was no problem in the version before 0.20, but it became 1.0, and it became difficult to use Japanese input with IME in the text area of ​​multi-line input.

0.20.7 1.0.3

I guess it is due to the change of the library of the text area of ​​multi-line input. I think it's the same for other languages ​​that use IMEs.


There seems to be no problem with the following combinations.

  • OS: Mac Catalina
  • IME: Google IME
  • Node-RED@1.0.3
  • Node.js@10.13.0

Is this a problem specific to Windows?

By the way, ace.js doesn't seem to be updated from 0.20.4.

On the latest Chrome and Firefox on Windows 10, I encountered the same problem in Node-RED v1.0.3. There's no problem on Internet Explorer. The object name of the horizontal scroll bar seems to be "composition" but there's no information to solve the problem on the Internet.

I also tried the following procedures to update ace but the result is the same.

It seems on firefox 71 / Chrome 79 with windows 10 windows IME.

I tried it with a plain sample program of ace editor 1.4.3, but I didn't see any problems with Japanese inline input in Node-RED 1.0.3.

I modified CSS as follows. It seems to work correctly on the latest Chrome, Firefox and IE on Windows 10 (I haven't checked browsers on macOS yet).

1 Like

On my Safari, Chrome, and Firefox on macOS, it worked correctly. Therefore, I submitted the following pull request.


After applying the presented patch and checking it with Firefox / Chrome on Windows 10, it can now be displayed correctly!

@utaani Thank you for checking the patch, Ueno-san!

On Firefox

1 Like