Tinkerboard GPIO issues

#1

Hi there, anyone tried Node-red on tinkerboard yet? im having trouble getting to use the gpio pins.
suggestions?

Karl

0 Likes

#2

have tried with the node-red-contrib-gpio, it looked as if it could possibly work with the Particle/tinker option,
atleast it does not report any error, but hangs on “connecting”.
all other functions are lightning fast compared to rpi3b+, would be nice to be able to use the gpios as well

Karl

0 Likes

#3

Any thoughts? im determined to get this functioning, but i need some help. what ive seen sofar, the tinkerboard is a beast compared to the rpi3b+

Karl

0 Likes

#4

If you want to use it to control GPIO pins I think you’ll have to write a node yourself.

AFAIK - the major use case of these is for 4K video - being a “beast” isn’t really relevant for GPIO stuff

All my Node-RED IoT is running on PiZeros :slight_smile:

Simon

0 Likes

#5

hehe, the beast ref is to other parallel functions, and reason for wanting gpio control

Karl

0 Likes

#6

Enabling GPIO pins
https://gobot.io/documentation/platforms/tinkerboard/
https://tech.scargill.net/a-new-gpio-in-town/

I used orange gpio and set it in (other) and put the numbers in pin 8 (161) place 161 and so with the others, but the outputs work fine, but the inputs give problems, and I agree that it is a tremendous plate , since I developed an application in rpi and the more the application increased the slower it became, instead with tinkerboard everything flows very fast. I hope someone develops something for tinkerboar.

0 Likes