Ui_base Error with Node-red-dashboard on TheThingBox

Any help??

Stuck for 3 days!!!


Welcome to Node-RED    

===========================
24 May 10:58:39 - [info] thethingbox version: v2.8.0
24 May 10:58:39 - [info] Node-RED version: v0.17.5
24 May 10:58:39 - [info] Node.js version: v6.11.1
24 May 10:58:39 - [info] Linux 4.9.35+ arm LE
24 May 10:58:45 - [info] Loading palette nodes
24 May 10:59:12 - [warn] ------------------------------------------------------
24 May 10:59:12 - [warn] [ui_base] SyntaxError: Unexpected token ...
24 May 10:59:12 - [warn] ------------------------------------------------------
24 May 10:59:12 - [info] User directory : /root/userdir/
24 May 10:59:12 - [info] Flows file :
/root/userdir/flows.json
/root/thethingbox/node_modules/node-red/flow/SoundManager/flows.json
/root/thethingbox/node_modules/node-red/flow/TaskManager/flows.json
/root/thethingbox/node_modules/node-red/flow/flows.json
24 May 10:59:12 - [info] Server now running at http://127.0.0.1:80/
24 May 10:59:13 - [info] Waiting for missing types to be registered:
24 May 10:59:13 - [info] - ui_base

image

we haven't supported nodev6 for a long time....
You need at least 8 (and even that is now end of life) so at least 10, or 12 recommended.
And Node-RED itself is now v 1.0.6...
You may be able to find an old version of dashboard - maybe 1.x - but I wouldn't really recommend going that far back.

1 Like

I kinda feel the problem should be there.

I installed another old module called: "node-red-contrib-ui" which worked for the ui page! But overlaps with dashboard.

I am using TheThingBox on arm v6 (RPi Zero) which I feel is very old.
How can I upgrade Nod versions with having TheThingBox running?

I have never heard about TheThingBox but at least their website mentions a newer version which has Node 10.x and Node-RED 0.19.6: http://thethingbox.io/docs/whatsnew.html

Can you upgrade your device?

Yeah but it is not compatible with arm v6 (Raspberry pi zero).
http://thethingbox.io/

well it seems like your options are

  1. Use that arm6 version of thingbox with node-red-contrib-ui - and uninstall node-red-dashboard (as they will conflict) - knowing that it is out of support and no security patches (but probably ok for use on an isolated network)
  2. use latest nodejs, Node-RED and node-red-dashboard - but drop thingbox.

Up to you.

I tried upgrading (installing) node-red from this link:

https://nodered.org/docs/getting-started/raspberrypi


Running Node-RED install for user root at /root on raspbian

This can take 20-30 minutes on the slower Pi versions - please wait.

Stop Node-RED :heavy_check_mark:
Remove old version of Node-RED :heavy_check_mark:
Remove old version of Node.js :heavy_check_mark:
Install Node.js for Armv6 ✘ Failed to install Node.js - Exit
Clean npm cache
Install Node-RED core
Move global nodes to local
Install extra Pi nodes
Npm rebuild existing nodes
Add shortcut commands
Update systemd script

Any errors will be logged to /var/log/nodered-install.log

root@mysolarserver:~/userdir #

Does the error log show anything useful?

Install nodejs first (e.g. [like this])(https://desertbot.io/blog/nodejs-git-and-pm2-headless-raspberry-pi-install) then run the installer script again. It should leave nodejs as is and install node-red without issue.

1 Like

Thank you. I eventually made my mind to move on!

"TheThingBox" was made just to simplify the process for Beginners and to quickly design their project by just installing one image file and start their raspberry pi.

I got my hand on the raspberry pi last Monday for the first time. However, I learned many stuff in the past week much enough to use the original procedure for creating a server.

:heart_eyes: :heart_eyes:The new version is really lovely.

I did:

1- Raspbian Buster Lite
Minimal image based on Debian Buster

2- upgrade node-red using this command:

https://nodered.org/docs/getting-started/raspberrypi

3- Run: "sudo apt update"

4- Run: "sudo apt install nodered"

5- Run: "sudo apt upgrade"

6- Run: "sudo apt full-upgrade"

7- Run: "sudo apt autoremove"

8- Run: "sudo apt-get clean"

9- Restart your raspberry pi:

"sudo reboot"

10- Congratulations! your raspberry pi has been updated and Node-red is ready.

At the end:
Some useful node-modules:

npm install node-red-dashboard
npm install node-red-node-arduino

For the server I tried one of the bests: (Free version enough)

Here are a the pics:

2 Likes

Welcome aboard. Hope you have lots of fun with it

Thanks for the quick responses.

No need to do that, the getting started script installed node-red for you, the latest version rather than the one from the Raspian repository. However, at the moment the one in the repository is also the latest so it won't have done any harm.
For the record, apt full-upgrade does the same as apt upgrade plus possibly a bit more, so you didn't need to do upgrade either.

That is right. I implemented the whole process two times and realized that step does nothing. I just saw that in a credible YouTube video. It has no harm though.

Latest version of node-red is installed in the second step.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.