Unable to install Chatbot from Hassio add-on

#1

I started to install the chatbot module about a month ago and ran into issues. I posted this log over on the Home Assistance forums thinking that it might be something wrong or missing with the HomeAssistant add-on, but I didn't get any responses other than a couple of other users having the same issue. To my understanding, the npm install should install all of the pre-requisites but from looking at the logs that may not be the case. Below is the log (Edit: I updated with the log from the attempt today). Please let me know if you have any ideas I'm willing to try anything. Thanks in advance.

29 Mar 13:01:09 - [info] Installing module: node-red-contrib-chatbot, version: 0.16.6
29 Mar 13:03:41 - [warn] Installation of module node-red-contrib-chatbot failed:
29 Mar 13:03:41 - [warn] ------------------------------------------
29 Mar 13:03:41 - [warn] npm WARN deprecated @types/p-cancelable@1.0.1: This is a stub types definition. p-cancelable provides its own type definitions, so you do not need this installed.
npm WARN deprecated @types/p-retry@3.0.1: This is a stub types definition. p-retry provides its own type definitions, so you do not need this installed.
npm WARN deprecated snekfetch@3.6.4: use node-fetch instead
npm WARN deprecated socks@1.1.10: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0
node-pre-gyp WARN Using request for node-pre-gyp https download
node-pre-gyp WARN Tried to download(404): https://node-precompiled-binaries.grpc.io/grpc/v1.19.0/node-v64-linux-arm-musl.tar.gz
node-pre-gyp WARN Pre-built binaries not found for grpc@1.19.0 and node@10.14.2 (node-v64 ABI, musl) (falling back to source compile with node-gyp)
gyp ERR! build error
gyp ERR! stack Error: not found: make
gyp ERR! stack at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)
gyp ERR! stack at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)
gyp ERR! stack at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)
gyp ERR! stack at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16
gyp ERR! stack at /usr/lib/node_modules/npm/node_modules/isexe/index.js:42:5
gyp ERR! stack at /usr/lib/node_modules/npm/node_modules/isexe/mode.js:8:5
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:154:21)
gyp ERR! System Linux 4.4.50
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--library=static_library" "--module=/config/node-red/node_modules/grpc/src/node/extension_binary/node-v64-linux-arm-musl/grpc_node.node" "--module_name=grpc_node" "--module_path=/config/node-red/node_modules/grpc/src/node/extension_binary/node-v64-linux-arm-musl" "--napi_version=3" "--node_abi_napi=napi" "--napi_build_version=0" "--node_napi_label=node-v64"
gyp ERR! cwd /config/node-red/node_modules/grpc
gyp ERR! node -v v10.14.2
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/usr/bin/node /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --library=static_library --module=/config/node-red/node_modules/grpc/src/node/extension_binary/node-v64-linux-arm-musl/grpc_node.node --module_name=grpc_node --module_path=/config/node-red/node_modules/grpc/src/node/extension_binary/node-v64-linux-arm-musl --napi_version=3 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v64' (1)
node-pre-gyp ERR! stack at ChildProcess. (/config/node-red/node_modules/grpc/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack at ChildProcess.emit (events.js:182:13)
node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:962:16)
node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:251:5)
node-pre-gyp ERR! System Linux 4.4.50
node-pre-gyp ERR! command "/usr/bin/node" "/config/node-red/node_modules/grpc/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build" "--library=static_library"
node-pre-gyp ERR! cwd /config/node-red/node_modules/grpc
node-pre-gyp ERR! node -v v10.14.2
node-pre-gyp ERR! node-pre-gyp -v v0.12.0
node-pre-gyp ERR! not ok
npm WARN discord.js@11.4.2 requires a peer of bufferutil@^3.0.3 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of erlpack@discordapp/erlpack but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of node-opus@^0.2.7 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of opusscript@^0.0.6 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of sodium@^2.0.3 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of libsodium-wrappers@^0.7.3 but none is installed. You must install peer dependencies yourself.
npm WARN discord.js@11.4.2 requires a peer of uws@^9.14.0 but none is installed. You must install peer dependencies yourself.
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! grpc@1.19.0 install: node-pre-gyp install --fallback-to-build --library=static_library
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the grpc@1.19.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2019-03-29T17_03_41_438Z-debug.log
29 Mar 13:03:41 - [warn] ------------------------------------------

0 Likes

#2

Its trying to build the software but hasn't got the tools to do so.

What operating system are you running this on?

0 Likes

#3

Running under HassIO on a raspberry pi 3. Node red is running and has been up and running for a while now on the install. I also have several other modules loaded in the Node-red environment. If you need any other info just let me know.

0 Likes

#4

Not all nodes need to be built, but if they do they need the tools to build them.
Not sure how you get them on HassIO, its probably a question for their forum.

How to do it on Raspbian is listed https://nodered.org/docs/hardware/raspberrypi

0 Likes

#5

Awesome! Thank you for the response. I will add these notes to the post over in the HassIO forums and see if I get any bites there. I am wondering if there is an add-on that they have to include these tools, since it does not have access to the command line. I will definitely check that out thanks for the info. What tools specifically am I looking for?

0 Likes

#6

Well your error post says it can't find make , the post I linked to includes the following:

On really minimal Debian installs you may need to run sudo apt-get install build-essential before running the script so that the serialport builds and installs OK. This is optional.

0 Likes

#7

Sometimes you also need the python2.7-dev package, but generally build-essential should be enough.

0 Likes