Websocket startup time issue when doing a deploy in node red


#1

Hi
Im running node red on a raspberry pie 3 (b+) with Hassio.
Hassio 0.86.4
Node red 1.3.0

I while a go I started to get connection problems when deploying a new flow in node red, see below. Any one got an idea what it may depend on?
Is there any way I can delay the service calls for 5 second when doing a deploy?

//Johan

7 Feb 22:09:40 - [info] Stopping flows
7 Feb 22:09:40 - [info] [server:Home Assistant] Closing WebSocket http://hassio/homeassistant
7 Feb 22:09:40 - [info] Stopped flows
7 Feb 22:09:40 - [info] Starting flows
7 Feb 22:09:40 - [info] Started flows
7 Feb 22:09:41 - [warn] [api-call-service:Turn on Stars] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Turn on Julbelysning framsida] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Turn on Fontän] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Turn On Vardagsrum] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Guldlampa på] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Fönsterlamp kök] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Fönsterlamp Vardagsrum] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Turn On Växtlampa tvättstuga] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Turn Off Växtlampa förråd] Call-Service attempted without connection to server.
7 Feb 22:09:41 - [warn] [api-call-service:Turn Off Motorvärmare] Call-Service attempted without connection to server.
7 Feb 22:09:45 - [info] [server:Home Assistant] WebSocket Connected to http://hassio/homeassistant


#2

As they are "[warn]" rather than "error", does it then connect properly?
If it does can't you just ignore them?

The current version of Node-RED is v0.19.5 not sure what 1.3.0 is !


#3

They look like messages from the api call service trying to talk while the home assistant service is not ready. So they need to handle that between them.


#4

1.3.0 is the version of the Node red addon for Hassio (Home assistant), Node red version is 0.19.5
It does connect properly but as I see it Node red doesn't wait until the connection is established. It just send the service call ASAP after a deploy.
So is there a way to delay node red for say 5s before it starts to do the calls?


#5

we don't know what you are sending to what ... so hard to advise. You can use a delay node to delay messages - but you probably don't want to delay messages after the initial 5 secs.