Whatsapp notifications node

Hiya... Just to share. We've created a simple node to have node-red send messages to one's mobile.
Extremely simple service, one green box. Free service, no personal data, no trick. Made for fun, shared for good.

Instructions are described on the node page at:

3 Likes

Moved to category "Share Your Nodes" :slight_smile:

@alsak0de I'm trying to use this node in China, my local server is permanently connected to a VPN and I use the Telegram bot very successfully.
Is there a reason why it will not work using a Chinese phone number? I have a token and I'm using the same WhatsApp phone number.

Unless there's some Whatsapp / US type of policy preventing the communication with a Chinese number, it should work smoothly.
Do you regularly use whatsapp from China to chat with numbers outside? If so, there's no difference. No magic here but a nodejs whatsapp interface

BTW, if you got the token reply.. means it worked.
Can you detail what is happening?

@alsak0de A bit of background first. I'm British and I work in China, I have a local server running Node Red and a VPN internet connection to allow me to "jump over the Great Wall", and I use WhatsApp daily to communicate with family and friends outside China.
I use the Telegram node to give me daily updates on the weather, AQI outside and inside my home and financial exchange rates, this works well but it just means another APP on my phone! When I came across your WhatsApp node I thought I could dispense with Telegram.

Details:
I requested a token through WhatsApp whin and I received the token. Okay

I imported your sample flow and inserted the token and the same phone number. Okay

When I inject the message the debug node connected to the inject node displays "hello from node-red-contrib-whin". Okay

Shortly after the the debug node connected to the whin node displays "message received". Okay

So, it seems to be working okay but where is the message in WhatsApp?

Not sure I'm getting this right, I'm reading you did receive the initial text with the token first so no issue on the 'Europe to China' thing.
Also, it is my understanding that the 'hello world' imported flow worked fine and you did not only received the 'OK' but the text on your phone, correct?
And finally, I suppose your flow did not send you the text you injected for some reason but you got the "message received" output from the debug.
If so; please check you're injecting a text/string into the node. Would you mind sharing your flow?

Would you mind sharing your flow? Are you sending th

@alsak0de

Yes I did receive the initial text containing the token so no issue there.
The inject node in your sample flow injects a string "hello from node-red-contrib-whin". This is okay.
After about 3 seconds the debug node connected to the whin node displays:- payload: "Message Received"

Here is your sample flow I am using with my credentials.

[{"id":"4996134e.719f3c","type":"tab","label":"Flow 4","disabled":false,"info":""},{"id":"efd5d46d4d8baab4","type":"whin","z":"4996134e.719f3c","name":"","auth":"ae5886e5.c87bc8","x":650,"y":360,"wires":[["4703f7051e36f3da"]]},{"id":"8c62536e8bf67956","type":"inject","z":"4996134e.719f3c","name":"","props":[{"p":"payload"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"hello from node-red-contrib-whin","payloadType":"str","x":475,"y":360,"wires":[["efd5d46d4d8baab4","49e5dd7a.67dcb4"]]},{"id":"4703f7051e36f3da","type":"debug","z":"4996134e.719f3c","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","statusVal":"","statusType":"auto","x":800,"y":435,"wires":[]},{"id":"49e5dd7a.67dcb4","type":"debug","z":"4996134e.719f3c","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","statusVal":"","statusType":"auto","x":660,"y":320,"wires":[]},{"id":"ae5886e5.c87bc8","type":"whin-config","name":"whin","phone":"86153******60","token":"5fabd0aee**********ff9ef8ea8991156e5262"}]

I do not receive anything on my phone WhatsApp..

I am affraid this must be something related with the data format you're sending.
Can you please check:
0.- which node-red-contrib-whin version have you installed?
1.- try to send a simple string text through the node, and verify your phone receives the text message. (If this doesn't work, there must be something wrong on your config node: most likely the token/phone is wrong, copy / paste them again and initialize).
2.- try to stringfy whatever datatype you're sending. (i.e. If you are sending a json object, you must set data type to string first.)

When I imported your sample flow, changed the config to my token/phone, and deployed... this is what I received:
image

@alsak0de I will check which version I’m using when I get back home.
The telephone number is correct and if I change one character of the token the debug node displays “error” and not “received” so the token must be correct.
The message I’m trying to send is exactly the same as in your sample flow, nothing else or different.
Maybe it has a problem with VPN connections and/or Chinese numbers.
It’s a shame because this is just what I’ve been looking for.
Merry Christmas.

No way this is VPN stuff. It might be our bad, something at our end related to versions.
So as suggested by lu4t, pls check, write it down and then try to update directly through NR palette.

Just tried this out today and all seemed to go exactly the same as per

But no message appears on my phone

I'm in England so no Great Firewall :slight_smile:

What release of the node are you using? Have you tried upgrading?

i installed it this morning

wow... I see.. that's weird. Let's see if we can figure out what's wrong.
Did you fill in the token and phone number into your whin config node?
If so, pls make sure you're using full format number with country code but no + sign at the begining.
Did you try the example flow work?

I had +44

Changed it to just 44 and it worked
Ta :slight_smile:

1 Like

Great! thanks for sharing.

@ rha10 may I ask you to check the same thing? can you make sure you're adding the phone into the config node with the right format?

Help!

2021-12-25T19:17:20.254Z [err] Not compatible with your version of node/npm: json-rpc2@1.0.2
2021-12-25T19:17:20.254Z [err] npm ERR! notsup Required: {"node":"0.10.x || 0.12.x"}
2021-12-25T19:17:20.254Z [err] npm ERR! notsup Actual: {"npm":"8.3.0","node":"v17.3.0"}

humm.. I can't really tell what the problem is here.
Our node has no dependencies set as for either npm or node minimum versions.
You might ask this in another thread. You definitely seem to have npm & node up-to-date.
Not sure what the issue is. All I can tell you is that with a clean install today, the node works perfectly fine.
Did yo have trouble with any other package install?