World Map showing outdated results

Quick question, I wanna know if there is anyway i can choose options other that the dropdown menu options of "Base Map" field.

I get different results when i see this location on node red and on another website which lets me pick apple maps.

Any idea how i can rectify this?

Map which shows correct image,47.497995,18

Try plotting those coordinates in node red and it shows nothing like what the above link does.

Any help appreciated

The maps come from openstreet map AFAIK, can you verify the same location ?

30.039892, 47.495122 are the coordinates i pushed to the link you asked me to try, but it does not show the result as shown in the attached image below.

Not sure why :face_with_raised_eyebrow:

If you know of a map server that you can source those tiles from then you can probably point worldmap at it - but yes the default Esri satellite layer that they make available for free does seem to be a bit behind the curve.

(edit: - you may be in luck - have found another version - just experimenting)

1 Like

In the link i provided, there is a button called switch map. If you choose the Satellite view & esri map, it populates the view too. Which i assume is the same setting as the default esri satellite layer in node red.

Not sure what is the difference between what node red is pulling and what the link i shared is using.

Try worldmap v2.5.3

[{"id":"fd654fbf.7e7db","type":"worldmap","z":"846d7832.3348c8","name":"","lat":"30.031761","lon":"47.513723","zoom":"14","layer":"Esri Satellite","cluster":"","maxage":"","usermenu":"show","layers":"show","panit":"false","panlock":"false","zoomlock":"false","hiderightclick":"false","coords":"none","showgrid":"false","path":"/worldmap","x":500,"y":540,"wires":[]}]

No Luck :frowning:

Are you sure you installed the latest version ? and refreshed you browser cache ?
I now get

Which looks like what you wanted.

Worked for me. Don't forget that you need to stop/start NR after installng the node. The other thng I noticed is @dceejay example did not use the exact same coordinates or map level 17 that are shown in your image, but when I changed it to those settings, the images it is dead on:

Spot on ! Works like a charm !
Thanks for the help guys !

Both your answers saved me but i can mark only one as a solution.
I did a cache refresh, stopped services and restarted node red services and it worked !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.