XMPP node startTLS

Just trying to use the XMPP node with public servers on the internet.
They all use starttls or SSL or the like...
Does this node not support such things? Since I can't get it to connect to any public servers I've tried.
Thanks
Chris

Certainly used to ... any servers in particular ?

I have tried jabber.uk and chat.sum7.eu ... so far.
Says connection error on both.
Think it's because the node doesn't do encryption maybe?

xmpp.is seems to work. normally things like openfire use port 5223 for xmpps but that doesn't seem to work either. We are using the main xmpp.js/packages/client at main · xmppjs/xmpp.js · GitHub library - but even the simple examples they have don't seem to connect...

Thanks for that. So your finding the same?
although xmpp.is does work for you?
But those I've tried don't work for you either?

Thanks again

looks like xmpp.is works, but in order to send from my phone I have to disable encryption in the app.
Which isn't ideal...
The app is saying that the recipient (node-red) doesn't support OMEMO encryption.
Is that anything to worry about?

not ideal but indeed maybe a clue.
OMEMO is an extension for encrypting one to one chats I think... and no I would be surprised if this client library supported it, as it's an optional extra - XEP-0384: OMEMO Encryption

OK.. Have a hard time with this.
Using xmpp.is , unencrypted, created a private room with my phone app.
Seems to work when messaged directly from phone to node-red
invited the node-red to a private room (created using phone)
then changed the node to: Buddy = roomname@muc.xmpp.is
But it never sees the messages sent to the room....
Think maybe it a bad job and I should give up, lol.

Working good here

was that created as a 'private room' ?

No was one I just "found" there.
then again - just created one with a password.. also ok.

OK, I'm using the room as an IN node.
and the room was created as 'private room'

The desktop client I am using (Swift) just has enter room and then set password on it - and it automatically creates and configures it...


Thanks
I think maybe the node-red doesn't auto join the room.
So not sure how to do that, perhaps login elsewhere...
Seems to be really difficult. been at it for hours. about to give up as been to hard.

auto-join works - but I'm not sure auto-create does. If you have created with phone then Node-RED should join ok.

yeah it would not join.
I restarted the whole xmpp node, server setup and all, then it suddenly joined.
Thanks for your help.
Weird thing is after messing with it for awhile you start to get many duplicated messages coming in.
Chris

1 Like