Automatic Node Status Missing?


Hey All,

I just did a full rebuild of my home automation system and during that work I moved from v0.17.5 to v0.18.7 and have noticed a small change that I don’t know is something that has just been removed or is something I can enable again in settings.js or somewhere else in the UI.

Previously I would notice that the status of nodes would update with a dynamic status when executed, like how much time a delay had left or the command a service node would call. An example is in the following image.

So anyone have any ideas? Thanks a lot!




Open up the Settings dialog from the drop-down menu and ensure the Show node status option is ticked on the View tab.



Thanks @knolleary. I already tried that and nothing. In my v0.17.5 instance I would get those status messages and the little “lights” would blink also, now I don’t see that anymore.



Any errors in the browser javascript console?

The editor uses a websocket connection back to the runtime to get those status updates. It also uses it for Debug messages; can you check the debug sidebar is working for you? That will rule out an issue with the connection.



I do since this:

[Warning] Deprecated include of L.Mixin.Events: this property will be removed in future releases, please inherit from L.Evented instead. – "checkDeprecatedMixinEvents↵extend↵↵eval code↵eval@[native code]↵" vendor.js.2.2627

But when i run anything with a debug node on, it does show in the debug sidebar just fine.



So looks like it might actually be the node itself that has the issue:

Thanks for trying to help me out @knolleary.