Can't remove node-red-contrib-gpio

I installed node-red-contrib-gpio and want to uninstall it. The pallette manager said it was in use but there were no nodes using it. I tried deleting the two config nodes firmata and ioplugin. Still can't remove it. Now when I start node-red I get:

5 Mar 17:46:00 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
5 Mar 17:46:00 - [info] Server now running at
5 Mar 17:46:00 - [info] Starting flows
5 Mar 17:46:00 - [info] [ioplugin:850be4f5.f2df88] error loading io class
1614984360299 Available Firmata
5 Mar 17:46:00 - [info] Started flows
5 Mar 17:46:00 - [error] [ioplugin:45e03009.9ea36] Error: Error: No such file or directory, cannot open /dev/ttyACM0

Any suggestions would be welcome. I have tried using admin. Same result. I tried stop and start in safe mode. Same result.


Welcome to the forum.

Use the Search feature (ctrl+F) and search for ioplugin and see if that finds the node generating the error.

First, though, open Configuration Nodes in the menu and select Unused, delete any unused ones and deploy.

is this on a raspberry pi?

have you run raspi-config and enabled GPIO ?

I managed to remove it. I went into the configuration nodes and changed the Firmata entry to Raspberry Pi and then I had two Raspberry Pi entries. I then removed one and deployed and now only one error. I removed the Raspberry Pi node and then uninstall worked. Something was just out of sync and my solution my not help anyone else. Thanks for suggestions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.