Change node in v1.3.0 not working

Last week I was running v1.2.9 (I think) and my flow worked great. I updated to 1.3 now and for some reason the Change nodes used in my flow have the red triangle, which I understand means an error in the config. When I click on any of the red triangles, it says "Invalid Properties: -rules"

I have a feeling there is a simple fix for this that I am missing.

Try adding in a new change node and set it with the rules you have and do a deploy and see if it works

Unfortunately the result is the same (red triangle with error "Invalid Properties: -rules").

Hi .. what if you update to the very latest release which is 1.3.1
It is mentioned in the changelog that something was fixed relating to the Change node form validation.

I am running Node-RED on an EC2 Debian instance and tried to install 1.3.1 but got the following:

Welcome to Node-RED

12 Apr 10:56:48 - [info] Node-RED version: v1.3.1
12 Apr 10:56:48 - [info] Node.js version: v12.19.1
12 Apr 10:56:48 - [info] Linux 4.9.0-12-amd64 x64 LE
12 Apr 10:56:49 - [info] Loading palette nodes
12 Apr 10:56:49 - [info] Settings file : /home/admin/.node-red/settings.js
12 Apr 10:56:49 - [info] Context store : 'default' [module=memory]
12 Apr 10:56:49 - [info] User directory : /home/admin/.node-red
12 Apr 10:56:49 - [warn] Projects disabled : editorTheme.projects.enabled=false
12 Apr 10:56:49 - [info] Flows file : /home/admin/.node-red/flows_ip-172-31-19-130.json
12 Apr 10:56:49 - [error] Unable to listen on
12 Apr 10:56:49 - [error] Error: port in use
nodered.service: Main process exited, code=exited, status=1/FAILURE
nodered.service: Unit entered failed state.
nodered.service: Failed with result 'exit-code'.

Opening the browser window still lists v1.3.0 and of course the red triangles are still there.

I do realize the above "Error: port in use" message means Node-RED is running, but in this case, I closed my browser window. Is there a more thorough way to stop Node-RED when running on an EC2 instance?

Closing the browser window just closes the browser window - it doesn't stop the server running.

How did you install Node-RED originally? Did you use the install script we provide or something else? If you did use our install script, you should have node-red-stop and node-red-start as available commands.

Otherwise, you could try rebooting the server.

Yes, I realized that closing the browser does not stop the server (sorry to have confused the matter...I realize that statement is repeated here a lot). I did originally install NR using the script, and typed node-red-stop in Putty (since that is how I am connected to the AWS Debian machine). Below is what I got (which seems to indicate the command worked). However, upon re-starting NR and re-launching the browser, it still says 1.3.0.

admin@ip-172-31-19-130:~$ node-red-stop

Stop Node-RED

Use node-red-start to start Node-RED again

All: Thanks for your suggestions. Upgrading to 1.3.1 and rebooting the machine fixed the Change node issues. Everything works fine now.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.