"Drop the flow here" bug

Hi, I'm doing a massive restyle of flow, sometimes when I was scrolling down I had this message, "Drop the flow here" , but it was easy to remove.. now it's not more possible. Since I've not deplouyed from 30 minutes, with many many changes, should I remove it out and deply to avoid loose all my changes??
Is it possible to avoid in future "Drop the flow here"? I don't need this feature it is risking to complicate my work. Thank you for understanding

there is no X button, not evident way to remove it out. ESC and all buttons doesn't work. WHat can I drop there to save my work?

I've solved dragging a simple txt file on browser, and I've imediately deployed all. I was really afraid to loose everything

It is always helpful to mention what version of NR you are using.

We fixed some issues with the 'Drop the flow here' overlay getting stuck in a recent 1.3.x release.

Hi, I have 1.35 version. As I said luckly it didn't completely froze the page, but esc key and clicks around didn't solve, there still a bug there. I'm using latest Firefox 89 0 2.
You may introduce a X button to close it

I regularly had this problem using Waterfox, but since I switched to FF for node-red I haven't seen it. It was still there after the known issue was fixed.

If you see things like these, please check the developer console for any error messages. Otherwise we have no chance of recreating it or even beginning to figure it out.

ok, where can I find developer console? I've googled about it but can't find

I determined that to cause it to happen in Waterfox (on Ubuntu), if I click and drag the same node several times then the Drop Flow popup flashes up and disappears, leaving the node selected and dragged about by the mouse even with the mouse button release. Clicking the mouse releases it, but if I then move it again then often the popup appears again and the page locks up (with the message up). There isn't anything unusual in the developer console. However, as I said, I can't get it to happen on FF so it may be a completely different issue. The previous thread is How to disable 'drop flow here' feature?.

@GiovanniG are you certain you are using node red 1.3.5? Do you see that at the bottom of the dropdown menu?

1 Like

I think it happened as you described, I've tried to reproduce the problem but it seems difficult. I still editing, if it happens again I'll focus more on last actions and see the developer debug, anyway I guess there are no errors there too
Yes 1.35

There isn't a 1.35. There is a 1.3.5.

1 Like

When I was generated the noted other topic/question, what you illustrate here 'seems' like or similar to FF scenario. But... I just have not triggered the sequence lately in FF. And push come to shove, I thinking different issue as well.

I tend to use FF more than anything else, not sure why, maybe just because it is the default.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.