Email notification error

I am using an external hardware (Advantech ADAM 6717) from which I need emails to be sent based on the readings. But, when I try to test the email functionality via the Node red on the hardware, I am getting the following error.

image

How to rectify it?
Am I doing a mistake here? I have connected the hardware to the static IP address for remote access. I am able to obtain the remote access, but only the email functionality is not working.

I am not using the node but 587 is STARTTLS
try 465. Also have you set up an app password on google security page, for apps that can not use MTA

I have tried with both 465 and 587. I still get the same error.

May I know what is the app password?
I have given the access in this [Sign in - Google Accounts]

did you create an app password there?
https://myaccount.google.com/u/1/apppasswords

When I tried loggiing in, I got the error

Are you using 2FA on your gmail account, if not you can not use app passwords.

I use this in other applications with no issue, but my gmail is 2FA and i have an app password.

The error is a dns lookup time out, so looks like a connectivity issue, are you using docker or similar?

As E1cid says, the EAI_AGAIN means that node red could not get an IP address for smtp.gmail.com, which suggests that either node-red cannot access the internet or that DNS lookup is not working correctly on your system.

1 Like

Thank you very much. I have remote access for my Node-RED on the hardware. So, I think I should find out why the DNS lookup is not working correctly.

If there is any methodthat I should try, please comment here.
Thanks again!

You said that you have configured it with a fixed IP. How did you do that? If you configured that in the device then you may probably need to set a DNS server too.

I have given the IP address for the static connection with Gateway, subnet and DNS.

Initially I used the DNS as 192.168.2.1 and then I was able to access the node red, but when I tried to change the DNS as per the network administrator's DNS servers, I get the screen as seen below.

I was able to connect another remote device with the same IP address and DNS, Gateway and subnet and was able to send the email notifications. But, with this particular device with node-red, I cant reach the node-red server also.

Also on the browser it shows that 'your connection isn't secure'. I dont have the option advanced to proceed further.

I am sorry and thankful to you guys! actually there was a connection problem and right after I made the correction, it worked well!

Thank you for the support as always! @Colin and @E1cid