Having problems to use MQTT with NodeRED in an embeded server

Hello guys!

I am trying to develop an application using NodeRED and share the data in the cloud (GCloud) by MQTT. For this, I am using the ADAM 6717 of Advantech which Is a gateway with NodeRED embedded.

I am having problems to connect the MQTT node to the broker. It never gets connected. I have read and tried a lot of things but nothing. I do really need help! (see pictures attached)


I haven't used ADAM 6717 but I would suspect, for security reasons, it could have a firewall or setting that prevents internet access by default?

If not, then perhaps it's DNS is not set correctly and therefore not able to resolve mosquito.org (hint, correct the DNS or use an IP address instead)

1 Like

Welcome to the Node-RED forum!

Can you ping the broker?
Do you have some kind of firewall between your system and the internet?
Which broker do you want to use in production?

1 Like

You could also consider giving other brokers a try.
Here is a link with an up to date list of free online mqtt brokers. (Scroll down until you see the heading "Online MQTT Public Brokers for Testing")

1 Like

I took a quick look at the 6700 series manual, and it appears to use an older version of Node-RED inside. This is likely irrelevant to the issue you’re seeing, but might be of value to others answering your question to keep in mind. Can you tap the 3 horizontal dashes top right and see what it shows on the bottom of that menu, is that 0.17.5 or something else?

1 Like

Hello afelix;

You are right, thats the nodeRED version. Here the proof.

Hello NodeRED Forum!

I did it. The is my GCloud IP and the is the ip of my adam through my internet router.

I just reliazed that maybe the problem was that I had connected the ADAM via Ethernet cable to my computer and maybe the firewalls were the reason why I couldnt.

Hello Steve-Mcl

Steve I dont have experience a lot with communications. Do you mean a firewall in my computer? How can I enable them? Thank you.

Thank you Stefan24

How can I enable the firewalls in my system and the internet?

How do you ping a broker?

Thank you.

Thank you for the information!

I don't understand that comment, can you describe how you have it connected in more detail please. Normally any device that needs to access the internet would be connected to your modem/router.

I waited for an answer from you to the questions from Colin.
If you have problems contacting another computer, you should DISABLE the firewalls (but only for testing!)
And you may ping another computer with


(I just used the IP address from your latest reply)

I suspect the guy has fixed it and not bothered to tell us, or has lost interest.

Hi colin,

Sorry for my late response but for some reason I was getting the notifications as Spam mail.

I had connected the ADAM6171 with an ethernet cable to my computer and another cable from the ADAM to my router. So due to the firewalls of my computer the adam couldnt connect to internet.

So, what I did was to get into the ADAM which is connected to the router via wifi from my laptop and it worked!


thank you. I did try by disable the firewalls in my computer just for testing and worked too.

Pardon me for my late response Colin.

Thank you so much for your help guys!!

1 Like

No problem, glad you got it working.

Apologies for casting nasturtiums, I do tend to get a bit over cynical sometimes, it is amazing how often a question is posted here, someone provides a possible solution, or suggests something to check, and we never hear from the poster again.


Thank you Colin!

Dont worry! I know you were just trying to help so, I do apologize for my late response. Take care.

This forum is amazing!!!!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.