How to open Node-Red in local system from linux server via putty

I have installed Node-Red in a linux server which I access it via putty.

I am able to start the node red server by running node-red in the terminal of putty. But how can I access the GUI in my local web browser (not from the browser of linux server) ?

Just use the IP address of the server and port 1880 eg

hostname:1880 might work too.

If jbudd's suggestion does not work, it is likely because something is blocking the network traffic.

That might be the local firewall on the server or it might be a router between your local PC and the server.

This did not work in my case. I am not sure whether it Is because of a firewall or something else.
Is there any other way to access the GUI?

Show us how you connect putty to the server,
and what you see in putty when you start node red.

And the IP addresses of your PC and Node-red server

It is a web page - what other ways would you expect?

Do I need to use any port forwarding in putty?

I enter the server address and then sign in as root and then perform a ssh login.

Once I start node-red in putty, I see the typical start message of node-red saying your server is running at


We know that you can log in to your Linux computer by ssh.
Run the command ifconfig | grep inet and look for an IP address. Not
This is the IP address that you need to use in your browser with :1880 after it.

It is usual on Linux to arrange for Node-red to run automatically when the computer starts up. Have you not done this?

No-one should ever log in to a Linux system as root. It is inviting all sorts of problems in the future.

Even using that IP address along with :1880 does not open Node-Red and shows This site cant be reached

Please do what I asked and show us the full startup log. Copy/paste please, not screen shot.
You are leaving the putty terminal open when you run the browser I assume.

Here is the start up log

hannan@ansible:~$ node-red
11 Apr 06:30:12 - [info]

Welcome to Node-RED

11 Apr 06:30:12 - [info] Node-RED version: v3.0.2
11 Apr 06:30:12 - [info] Node.js  version: v18.15.0
11 Apr 06:30:12 - [info] Linux 5.15.0-67-generic x64 LE
11 Apr 06:30:13 - [info] Loading palette nodes
11 Apr 06:30:14 - [info] Settings file  : /home/hannan/.node-red/settings.js
11 Apr 06:30:14 - [info] Context store  : 'default' [module=memory]
11 Apr 06:30:14 - [info] User directory : /home/hannan/.node-red
11 Apr 06:30:14 - [warn] Projects disabled : editorTheme.projects.enabled=false
11 Apr 06:30:14 - [info] Flows file     : /home/hannan/.node-red/flows.json
11 Apr 06:30:14 - [info] Creating new flow file
11 Apr 06:30:14 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

11 Apr 06:30:14 - [warn] Encrypted credentials not found
11 Apr 06:30:14 - [info] Server now running at
11 Apr 06:30:14 - [info] Starting flows
11 Apr 06:30:14 - [info] Started flows

Yes the putty terminal is open when i run the browser

Are you logging in as hannan now? You should be.
What does this command show in putty, logged in as hannan?
ip addr

Yes I am logging in as hannan

hannan@ansible:~$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: ens18: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether de:3f:30:dd:a6:b7 brd ff:ff:ff:ff:ff:ff
    altname enp0s18
    inet brd scope global ens18
       valid_lft forever preferred_lft forever
    inet6 fe80::dc3f:30ff:fedd:a6b7/64 scope link
       valid_lft forever preferred_lft forever

What ip address are you using to connect using putty? and exactly what are you entering in the browser address bar?

The ip address I enter in putty is different. Once I enter that IP address in putty, then I login as root (that is how the instructions are for using that server) and then I perform ssh login to hannan @

In browser I enter . I get this IP address from ifconfig after ssh login

Why is it different? To access node-red via a browser you must be able to directly access it from the machine running the browser. It sounds as if you are trying to connect to a different network, or something simiilar. You need to tell us more about the network configuration.

This sounds like a managed server of some kind?

That is not logged in as root but as a user.

Also, the server's name is ansible? Is that the server name you are using to log in via SSH?

To open the GUI had to add these configurations in putty settings

In putty settings > Connection > SSH > Tunnels, added source port as 1880 and destination as ip-address:1880

Now able to access GUI from browser at localhost:1880