How to set up an alexa voice command correctly in nodered

  • I use the node-red-contrib-alexa-remote2-applestrudel in nodered.

  • I can get an external thermometer to read the temperature via the voice command "alexa external thermometer" but lately alexa responds with a description of the mercury thermometer interrupts them amid and then responds with the correct temperature values.

  • When writing the nodered stream and after a few months of operation it has always responded correctly; only ultimante presents the problem.

  • I would like to know if it happens to you and how you solved the 'anomaly.

1 Like

I can't say for sure what's causing your specific problem, but for quite a while I had several detailed flows to control Alexa with voice commands. In my case, I was able to turn on/off devices/lights at specific times with voice commands. But when they added that option to Alexa natively it completely broke many of my Alexa based flows. I'm still experimenting with how to make everything work like it used to.

1 Like

Your command is very terse, in these cases I find it helps to be more verbose

Does it work if you say "alexa what is the external thermometer temperature"

1 Like

I had already tried, but it still continues with the stupid thermometer explanations , do you know if there is a command to disable the explanations of the terms that alexa listens to?

From your description it seems like an Amazon issue rather than the node.

A couple of things to try

Change the name of the device to something more unique. eg garden
"alexa what is the garden temperature"

If you have no luck with that you could setup a Q&A "skill"

1 Like

As @smcgann99 suggested, the Q&A Skill in Blueprints might be helpful. Here's a link to a thread.

Last week I connected a SonOff S26 mains switch to power my colour laser.
As shown below I can utter various commands and ask for a status report.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.