🎉 Node-RED 2.1.1 released

I have just released Node-RED 2.1.1 - this fixes an issue with the TypedInput widget that prevented some options from being selected in the Inject and Trigger nodes (and elsewhere I'm sure).

I've also fixed the welcome tour so that the popout doesn't fall offscreen if your browser window is narrower than expected.


Thank you for the new version!

Here the switch node loses its outputs as soon as I edit it. I can copy an old switch node or create a new one, and at first it will have one output. If I edit the node, it has no outputs anymore. Adding another rule doesn't help, it still has no outputs.

Hi @elmicha

I cannot reproduce that locally. Can you export one of your switch nodes are share it here?

Please also check the browser console for any error messages.

Oops - it works without problems after I used shift-reload in the browser.

Very nice squire!!

a question:


The paper aeroplane?


Where do you see that?

That opens the Testing tab! Doesn't seem to be much you can do with it though :shushing_face:

ahem - ignore that. It'll disappear in 2.1.2....

And here I was hoping that it would cause my PC to sprout $100 bills.....

No. It’s for sending 100 dollar bills to Nick !


I tried.... Opened the drawer and took out the plastic shiny coffee mat... I put in 2 packs of them but the little drawer wouldn't stay closed... So i beat it closed.... Now it won't open until he collects them...

I'm having an issue with Dynamic MQTT subscription in 2.1.1
I can not get the node to output a parsed JSON object if dynamically configured, it always returns string.
Same node configured as Single Topic would return a json object for the same topic.
Seems to me like a bug.

Please raise an issue with details - thanks.

:+1: created

15 posts were split to a new topic: Node-RED 2.1.1 - PiZero install fail

I have an issue with my contrib-nodes related to the typedInput widget which occurs since 2.1.1 (didn't test 2.1.0 however). In the oneditprepare function, in order to set the type and value, I first call typedIput("value", value) and then typedinput("type", type) but upon the latter call, the value is erased. I use this order (first value, then type) because otherwise the context store is not correctly set for flow and global types. Additional info: The typedInput widget is part of an editableList widget.
I don't see any difference to what e.g. the change node does, but there it is obviously working.

Another problem that I see since 2.1.1 is that all spinner widgets I use in my nodes have a very small shape. Also here I don't see a difference to e.g. the delay node which also uses a spinner widget.

There were some fixes in the TypedInput to do better validation of values based on the current type.

This did reveal an issue with setting the value and then type, which the Change/Switch nodes were doing.

Some further fixes went in to the TypedInput to handle that better as well as some changes to those nodes to ensure they set the type then value as that is semantically more correct.

But no doubt there are edge cases my testing didn't reach. Can you share a link to your nodes so I can see exactly what they are doing and use them as a test case to see what we can do?

I can confirm there is a bug with the TypedInput when you have multiple context stores... will get that fixed for 2.1.2

Even if some problems have been fixed here, I have to ensure compatibility with older versions of Node-RED for my own nodes. The integrated nodes does not consider this, because they are aligned with a fixed node-red version. But this does not work for customer nodes. I know that a lot of users uses my nodes in an embeded version of Node-RED 1.2.9, which they can not update until a new version of the complete system is released. But they can install and update the custom nodes.

In the past I had some problems there with env and with global and flow contexts, which only working properly if I set the type first and then the value.

In the end, I need to do something like this to ensure compatibility to the old and new versions of Node-RED:

$field.typedInput('type', type);
$field.typedInput('value', value);
$field.typedInput('type', type);

I am well aware of this - which is why additional fixed went into 2.1.0... but it's clear there are cases where that hasn't worked. You shouldn't have to make any changes. I'm investigating at the moment.