🎉 Node-RED 1.1.0 released

We have just published Node-RED 1.1.0 - it is now available for all to install and enjoy.

If you haven't been following the beta releases, there's plenty to discover in this new release including:

  • A new look for the Information sidebar and a newly introduced Help sidebar
  • The ability to group nodes
  • An updated Inject node that can set any message property, not just payload and topic
  • and plenty more.

See the release blog post for more details: https://nodered.org/blog/2020/06/30/version-1-1-released

The updated Docker images are being built and will be available shortly.

Thanks, as ever, to those who tried the Beta releases and provided some great feedback on the new features.

26 Likes

Many thanks to Nick and all contributors for their hard work!

A lot of new features I'd never want to miss again. I was already impressed by the betas! Great work! :grinning:

1 Like

I'm definitely looking forward to installing it and using the outliner extensively.

1 Like

Great work, thanks.

Kudos to the team!

JSONata $moment support :slight_smile:

5 Likes

Hey, maybe I can retire the node-red-contrib-moment node! :upside_down_face:

4 Likes

Thanks for all the hard work and late nights. :star_struck:

Not to sound ungrateful (because I LOVE where Outliner is going), but are sorting options for the tree 'on the list' for a future release? :slight_smile:

Thanks again!!!

Yes. I did want to get then into this release, but they didn't make it.

2 Likes

Luckily there will be a 1.2 and 1.3 etc so lots of things are possible

3 Likes

Thanks Dave and Nick for all the hard work, greatly appreciated! :grinning:

Thanks! I totally get that you can't put everything in the first version of a new feature. And outliner is very useful as-is - much appreciated.

I upgraded my main/large production system to 1.1 last night (on accident, but that's another story lol), and it is working great.

Great work!

2 Likes

I didn’t have time to test the betas and just updated a test system on a rockpro64 to 1.1.0. Love all the new features but i have one big problem. I cant move around the workspace any more on an ipad. The only way i can navigate the workspace right now is with the navigator or by connecting an external keypad and using the keys. I can pinch to zoom but i cant drag the workspace around at all. The keys didn’t work before so its nice that they work now but its kind of a bad trade keys for no touch :upside_down_face:
Has anybody else tried it on an ipad yet and seen this issue?

Johannes

1 Like

I just tested and the only way I can get to work is to do a two finger pinch the put nmy fingers ofer the ares I want to see and do a two finger expand on that area. Clumsy.

1 Like

Thanks for the report. You may have seen issues were reported on Android during the beta, which I fixed. It's unfortunate we didn't get anyone trying it on an iPad.

I have no access to an iPad to investigate this. Normally I'd be able to borrow one in the office, but I'm not likely to be in the office for quite a while yet. So am limited in what I can do. Hopefully someone with a iPad can help diagnose the issue - happy to provide some pointers to possible causes.

1 Like

@knolleary let me know how I can help.

same here @knolleary

Same here, iPad Pro 12.9" 2nd generation available, running iOS 13.

1 Like

Based on a quick test I can confirm Android works great. In fact a lot better than previously. Now the editor area seems to stay put while dragging nodes or wires. Previously creating wires was occasionally impossible unless the view was panned to top left corner.

Sad to hear it's caused a regression on the iPad...